Indices/Field names autocomplete in Kibana console for non-admin users

Good day all,

I would like to know if there is a specific permission I need to grant to users to be able to get autocompletion on field names inside the Kibana console. It works fine if the user has all permissions (such as the admin user). However it does not work for regular users! Autocompletion works in general for regular users but not for fields names and indices names.

Highly appreciate your help.

Regards,
Hasan

Unfortunately, it seems that nothing happened since then :frowning:

Autocompletion works for the admin user and any user with * permissioms. But doesn’t for users with less permissions. That is why it seems to me more of a security behaviour in ODFE than a lost feature in OSS Kibana.

I am working with v 1.12 and it does not auto-complete for admin nor other user having * permissions. The same was with v1.10 that I worked before. Can you show a screenshot with autocompletion working? Try to auto-complete a field that you never typed before (the search box does remember the history). See mine in a browser with disabled history/cookies (typing a general host.name field existing in every document in my index and no auto-completion happens)

This is what I am talking about. The version here is 1.13.2. The user at the left is an admin (backend=admin) while the user on the right is a regular one. For the admin I can see autocompletion for indices names and fields names while the user on the right can only get autocompletion for DSL syntax. If I switch the user’s backend to “admin” then autocompletion works! However this is not practical since developers (and even less privileged users) will need autocompletion without the need for admin privileges.

Now I get why we misunderstood each other. You are talking about ‘Dev tools’ while I was talking about search box. And yes, you are right - a non privileged user does not have autocompletion while admin does. I will try to see what specific permission drives this and update if I find out.

@asfoorial

Did some reverse engineering and found minimum role settings to have autocomplete enabled for indices and fields. You only must add extra permissions to be able get data from index.

Got it working on 1.13.2

Thanks @pablo it works for me now on both 1.13.2 and 1.9.

1 Like