Deleting Open distro Alerting from Kibana

Hi, Alerting module keeps creating indexes daily on my elasticsearch,
How can I stop whole alerting module so that it stops creating indices.

Hi @nebi, to remove the entire plugin: https://opendistro.github.io/for-elasticsearch-docs/docs/install/plugins/#remove-plugins

To disable it, flip opendistro.scheduled_jobs.enabled to false: https://opendistro.github.io/for-elasticsearch-docs/docs/alerting/settings/#alerting-settings

Hi @aetter,
I already did this

But still I see new indices being created for opendistro on my ES for everyday.
Also my ES deployed on AWS, how can I run command for removing plugin on AWS ?

Hi @nebi, you can’t remove the plugin on Amazon ES, but now that you’ve disabled the plugin, try deleting the .opendistro-alerting-alert-history-write alias and all of the .opendistro-alerting-alert-history-<date> indices.

@aetter how am i gonna delete pendistro-alerting-alert-history-write alias ?

Run _cat/alias to find out which index it’s mapped to and then delete it.

The command will probably be something like DELETE .opendistro-alerting-alert-history-2019.10.17-1/_alias/.opendistro-alerting-alert-history-write.

If you don’t mind losing them, you can instead delete all the history indices, which gets the alias, too: DELETE .opendistro-alerting-alert-history-*.