Alerting config not persisted

Hi, I’m running OpenDistro with the security removed from both Elasticsearch and Kibana using Docker (images created per the documentation).

I wanted to change the config to make the Alerting config persistent can anyone explain how that can be done as it is all lost if I re-deploy the container.

Many thanks in advance…

Hi @alexbourne
As far as I know, you could specify settings in the directly in the docker compose file (https://www.elastic.co/guide/en/elastic-stack-get-started/current/get-started-docker.html#load-settings-file)
For example:

environment:
    - opendistro.alerting.monitor.max_monitors=1000
    - opendistro.alerting.alert_history_enabled=true

Besides, you could put the configuration in a yml file, and load it to the docker container.
For example:
Create a yml file, and specify your settings,

opendistro.alerting.monitor.max_monitors: 1000
opendistro.alerting.alert_history_enabled: true

Then create a bind mount in the volumes section of the docker compose file.
See the above link or https://opendistro.github.io/for-elasticsearch-docs/docs/install/docker/#configure-elasticsearch for detail.

This will make your Alerting config persistent.

Tianli