Why does Kibana log says “Checking Elasticsearch version” error?

Hi Guys,

I am trying to integrate openid with opendistro for my enterprise SSO.

here is the configuration details:
Elasticsearch version- 7.3.2
Kibana version-7.3.2

and i have installed security version 1.3.0.

seems like my elasticsearch cluster is running without any errors. but my kibana cluster pops me into error like “Checking Elasticsearch version” continuously.

and configured logging.verbose to TRUE to get cause of the error. but no luck.

does anyone have any idea on this what’s going on here?. Thanks in Advance!

i have found some suggestions from this thread Troubleshooting Security Plugin Issues

but it also didn’t help me much. moreover i’m not using any keycloak IDP for the setup.

can some one please get me out of this weird error?

i found that some parameter is missing in openid configuration document information.

I did setup that openid_connect_idp prefix in my configuration. But still it didn’t work for me.