When will the next release to support ES7.3

Hi,

I’d like to know the roadmap of release. When will the version support ES7.3 be released.

Thanks,
Xiao

ES 7.4 is even current now.

Does this support ES 7.4? Getting Unknown plugin error in ES 7.4. Please update

Hi Vinu,

We plan to release Open distro for Elasticsearch 1.3.0 early next week which will align with ES 7.3.

Thanks,
Pavani

1 Like

Hello Pavani,

I have clean installed opendistroforelasticsearch-kibana_1.2.1_amd64.deb on multiple “Ubuntu 16.04.4 LTS” host servers. All installations I am experiencing the same MAJOR BLOCKER, that after some research has leds me to believe that this issue was fixed in Kibana in more recent ES 7.3+ releases.

After installing opendistroforelasticsearch-kibana (1.2.1), Unfortunately I am experiencing a blocker when opening the Kibana security-configuration page using the latest Chrome (v79.0.3945.79 - 64-bit) and Firefox (v71.0 - 64-bit) Browsers, reporting "Refused to execute inline script because it violates the following Content Security Policy directive: “script-src ‘unsafe-eval’” in browser console and causing required missing icons to administrate ES.

I’m at the end of my rope and looking for solutions.
One major question I have is whether there is a more recent DEB release I can download and install today that would probably have this issue resolved without me having to spend more time reporting something that’s already been fixed in more recent releases of ES?

I could not find a page that gives me a release list to try other downloads and installations.
If this is the wrong forum, please direct me to where I should submit this request for help.

Hey Imit,

Sorry for the chase but can you file an issue in GitHub under Kibana. Also, we need details around the browser you are using, version, config, etc. Our developers will respond to your issue there.

Thanks,
Pavani

Hi Pavani, This was done and well well documented the same day I requested your help.
With 0 response.

Are you still releasing Elasticsearch 1.3.0 this week?
I’ve given up on Elasticsearch 1.2.1.

Hey @Imit,

We are planning to release Open Distro for Elasticsearch 1.3.0 by Wednesday and it has kept us busy. I will get back to you on this issue soon.

Thanks,
Pavani

OK Thanks.
The incomplete Kibana security-configuration page, seems to manifest when client-side SSL is enabled: “server.ssl.enabled: true” . I hope they test this in release 1.3.0. Its a critical feature for security-aware implementations. My goal is to get SAML implemented so, SSL is CRITICAL .