Unable to retrieve version information from Elasticsearch nodes

Hello Everyone ,

After i have installed 1.6.0 version of elastic search and Kibana , I am receiving the below error when i am trying to start Kibana using Kibana.bat.

E:\ELK\OpenDistro_Testing\ODForKibana\bin>kibana.bat
  log   [08:24:32.060] [info][plugins-service] Plugin "newsfeed" is disabled.
  log   [08:24:35.976] [info][plugins-system] Setting up [20] plugins: [usageCollection,metrics,timelion,apm_oss,uiActions,data,navigation,status_page,share,kibana_legacy,management,dev_tools,inspector,expressions,visualizations,embeddable,dashboard_embeddable_container,home,eui_utils,bfetch]
  log   [08:24:35.981] [info][plugins][usageCollection] Setting up plugin
  log   [08:24:35.986] [info][metrics][plugins] Setting up plugin
  log   [08:24:35.988] [info][plugins][timelion] Setting up plugin
  log   [08:24:35.990] [info][apm_oss][plugins] Setting up plugin
  log   [08:24:35.992] [info][data][plugins] Setting up plugin
  log   [08:24:36.003] [info][plugins][share] Setting up plugin
  log   [08:24:36.007] [info][home][plugins] Setting up plugin
  log   [08:24:36.025] [info][bfetch][plugins] Setting up plugin
  log   [08:24:36.040] [info][savedobjects-service] Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations...
  log   [08:25:06.064] [error][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes.

I tried to find solution but i don’t see any concrete information . We are using Kibana with Xpack enabled and i don’t see this kind of issue there . Please help me .