Status of Kibana Maps

Hey Jonah - Yeah let’s sync offline and see how we can help. We are planning on making sure we have an alternate available with the new fork which we will open up with the repos - but we can see if that works for you as a stop-gap. If anyone else has similar issues please let us know.

Carl

1 Like

Elastic and its ecosystem are becoming more and more toxic …

1 Like

This is an interesting thread! As mentioned above, the maps situation in the variants of Kibana is super-confusing… I am working with AWS Elasticsearch and Kibana but the relative lack of map capability is pretty frustrating.

Makes sense that AWS Elasticsearch uses an AWS endpoint for the default map tiles in Kibana (rather than Elastic.co ones). Fair enough. But there does not seem to be a way to configure the zoom level regardless of whether you bring your own tiles or not which seems like a strange omission, especially considering the client side logic is probably there.

Surely the default position should be to restrict zoom levels when using the AWS (or Elastic.co) end points for the map tiles? And if you can bring your own WMS then you can do whatever you like?
@searchymcsearchface

I don’t think the zoom level is anything native to the AWS map endpoint :face_with_monocle:

ah yes. good point! And raises the question why restrict zoom level at all?

1 Like

I don’t really know the reasoning for that. Of course, it has to stop somewhere of course.

Zoom on tiles is one of those exponential things - each zoom level squares the number of tiles needed.

I have tried to use some of the examples above, and I can’t seem to get anything to show up at all. I just installed 1.13.2, and I used the settings as shown in this thread in addition to activating WMS in the advanced settings. However the map part remains blank. When I try and tcpdump on my host, I don’t see requests for port 443 going out either.

Has something changed/broken recently? Is there something else I can set?

@sangdrax81 Interesting. Are you saying that you can’t see maps at all or only when use a custom WMS URL?

Well, I don’t have any working maps right now, but I thought the custom WMS URL was the only way to get maps as they were not yet shipped with any sort of working default?

You should be able to get maps without changing anything.

Then I guess I need more documentation than what I could find? When looking for maps in OpenDistro I find only this WMS Map Server - Open Distro for Elasticsearch Documentation which indicates that a WMS should be added. The Kibana configuration pointed to this URL, and indicated that the elastic map service should be shut off (or it defaulted to it being off).

When I make a map it is blank, and when I try and activate WMS maps from the above directions and examples directly from this thread, I still don’t get graphics for the map part. I am hopeful that there is just something additional that I need to configure, but I have followed the only directions I can find, and not really sure how to find further details about what is wrong. Any suggestions would be appreciated.

I keep looking for any traffic which might be blocked by a firewall etc, but I don’t see any traffic which makes me think I am blocking something from the Kibana node.

OK. That is a definite change. You can restore the maps by using the OpenSearch map tiles in OpenDistro. Add the following line to the kibana.yml file

map.tilemap.url: "https://tiles.maps.search-services.aws.a2z.com/tiles/{z}/{x}/{y}.png"

The WMS Map Server is something different, AFAIK.

Thank you, this is exactly what I was missing. I can turn off the WMS and now I have working maps.

— edit —
Actually I just checked and my WMS map I was working on the other day is now working as well. I don’t know if this somehow affected WMS maps, or if I just never restarted Kibana after turning it on… but now I have both working it would seem.

Interesting. Well, it seems the open source end point for Kibana maps is not working - this was a good call out regardless.