Snapshot restore without .opendistro_security requires admin certs

I’ve taken a snapshot with the body
{ "indices": "*,-.opendistro_security", "include_global_state": false }

(I get an index not found error if I just have -.opendistro_security without the *), but when I try to restore it I get an error that contains

{ "type": "security_exception", "reason": "no permissions for [] and User [name=snapshotrestore, backend_roles=[snapshotrestore], requestedTenant=null]" }

If I include the admin certificate and key the error goes away, but from reading the docs at https://opendistro.github.io/for-elasticsearch-docs/docs/elasticsearch/snapshot-restore/#security-plugin-considerations I shouldn’t have to do this for my snapshot. Is there something I can do to fix this?