Performance Analyzer plugin not parsing

Hi,

I have the opendistro setup using tarballs. I setup the service as mentioned in the site guideline. When I’m running the PA plugin I’m getting the below error message and the service is still running

[PA:Reader] [Thread-1] ERROR com.amazon.opendistro.elasticsearch.performanceanalyzer.reader.ClusterLevelMetricsReader - Skip parsing. Number of lines: 1.

Below are my config files:
opendistro-performance-analyzer.service
[Unit]
Description=Opendistro for Elasticsearch Performance Analyzer
PartOf=elastic.service

[Service]
ExecStart=/path/to/elasticsearch/bin/performance-analyzer-agent-cli
Restart=on-failure
User=Delas
Group=gelastic
Environment=ES_HOME=/path/to/elasticsearch
WorkingDirectory=/path/to/elasticsearch

[Install]
WantedBy=elastic.service

performance-analyzer-agent-cli
#!/bin/sh

PA_AGENT_JAVA_OPTS="-Dlog4j.configurationFile=$ES_HOME/plugins/opendistro_performance_analyzer/pa_config/log4j2.xml
-Xms64M -Xmx64M -XX:+UseSerialGC -XX:CICompilerCount=1 -XX:-TieredCompilation -XX:InitialCodeCacheSize=4096
-XX:InitialBootClassLoaderMetaspaceSize=30720 -XX:MaxRAM=400m"

ES_MAIN_CLASS=“com.amazon.opendistro.elasticsearch.performanceanalyzer.PerformanceAnalyzerApp”
ES_ADDITIONAL_CLASSPATH_DIRECTORIES=plugins/opendistro_performance_analyzer
ES_JAVA_OPTS=$PA_AGENT_JAVA_OPTS
dirname "$0"”/elasticsearch-cli
“$@”

performance-analyzer.properties

======================== Elasticsearch performance analyzer plugin config =========================

NOTE: this is an example for Linux. Please modify the config accordingly if you are using it under other OS.

Metrics data location

metrics-location = /dev/shm/performanceanalyzer/

Metrics deletion interval (minutes) for metrics data.

Interval should be between 1 to 60.

metrics-deletion-interval = 1

If set to true, the system cleans up the files behind it. So at any point, we should expect only 2

metrics-db-file-prefix-path files. If set to false, no files are cleaned up. This can be useful, if you are archiving

the files and wouldn’t like for them to be cleaned up.

cleanup-metrics-db-files = true

WebService exposed by App’s port

webservice-listener-port = 9201

Metric DB File Prefix Path location

metrics-db-file-prefix-path = /tmp/metricsdb_

https-enabled = true

#Setup the correct path for certificates
certificate-file-path = /path/to/elasticsearch/cert/cert.pem

private-key-file-path = /path/to/elasticsearch/cert/key.pem

WebService bind host; default to all interfaces

#webservice-bind-host =

Plugin Stats Metadata file name, expected to be in the same location

plugin-stats-metadata = plugin-stats-metadata

Agent Stats Metadata file name, expected to be in the same location

agent-stats-metadata = agent-stats-metadata

Can anyone please help me understand why this would be happening?

Hi,

Are you still having issues with this? Which version of Performance Analyzer are you using?

Could you also check that Performance Analyzer is enabled? You can enable it via the following command:

curl localhost:9200/_opendistro/_performanceanalyzer/cluster/config -H 'Content-Type: application/json' -d '{"enabled": true}'

Lastly, in your opendistro-performance-analyzer.service file I notice there are a lot of /path/to/elasticsearch lines. I assume you changed these for the sake of this post, but please double check that these paths are pointing to the appropriate locations.

Regards,
Sid