Org.opensearch.gradle:build-tools:1.1.0 was found

i want develop my ingest plugin and install it to opensearch. i clone the template and run gradle, it says

Could not resolve org.opensearch.gradle:build-tools:1.1.0.
Required by:
project :
No matching variant of org.opensearch.gradle:build-tools:1.1.0 was found. The consumer was configured to find a runtime of a library compatible with Java 8, packaged as a jar, and its dependencies declared externally but:
- Variant ‘apiElements’ capability org.opensearch.gradle:build-tools:1.1.0 declares a library, packaged as a jar, and its dependencies declared externally:
- Incompatible because this component declares an API of a component compatible with Java 10 and the consumer needed a runtime of a component compatible with Java 8
- Variant ‘runtimeElements’ capability org.opensearch.gradle:build-tools:1.1.0 declares a runtime of a library, packaged as a jar, and its dependencies declared externally:
- Incompatible because this component declares a component compatible with Java 10 and the consumer needed a component compatible with Java 8
- Variant ‘testFixturesApiElements’ capability org.opensearch.gradle:build-tools-test-fixtures:1.1.0 declares a library, packaged as a jar, and its dependencies declared externally:
- Incompatible because this component declares an API of a component compatible with Java 10 and the consumer needed a runtime of a component compatible with Java 8
- Variant ‘testFixturesRuntimeElements’ capability org.opensearch.gradle:build-tools-test-fixtures:1.1.0 declares a runtime of a library, packaged as a jar, and its dependencies declared externally:

These are artifacts exported by OpenSearch. If you’d like to build on top of released version of OpenSearch you could use releases maven repository in your build.gradle script: Index of /repositories/releases/org/opensearch

Here is an example: job-scheduler/build.gradle at main · opensearch-project/job-scheduler · GitHub

You could also look into our BUILDING.md documentation: opensearch-plugins/BUILDING.md at main · opensearch-project/opensearch-plugins · GitHub

1 Like

@vemsarat This means I should update that template repo - correct?

yes i clone it from github

should i clone project opensearch-build and install to local repo, then start dev new plugin?

I suggest you take @vemsarat’s advice here. I was asking if I should make the fix in the template repo if this is indeed a bug…

@amitai thats a good point.
I think we should update it to 1.2.0-SNAPSHOT

I would prefer to go with a SNAPSHOT version than the release because the development work is starting and its good to put efforts on the right direction.
What do you think?

1 Like

:joy: it was resolved. my gradle should be bind to java more than 11.

2 Likes