Opendistro_security.multitenancy.tenants.preferred parameter is not taking effect

I am using kibana security plugin 1.9.0 and have enabled multitenancy. Everything is working properly except opendistro_security.multitenancy.tenants.preferred is not having any effect on the ordering in the Tenants tab of Kibana. Even after configuring the parameter the list is coming in the default order.
Configuration in kibana.yml
opendistro_security.multitenancy.enabled: true
opendistro_security.multitenancy.enable_filter: true
opendistro_security.multitenancy.tenants.preferred: [“Private”,“xyz”,“Global”,“abc”]
elasticsearch.requestHeadersWhitelist: [ “Authorization”, “securitytenant” ]
Please check and suggest.
Thanks in advance

@Pratiksha During local testing I noticed same behaviour that you described, but later noticed that the tenant is stored from last session. Hence new session in incognito was able to default to the tenant specified in kibana.yml file. Can you check if you are getting the same behaviour using private browser?

Thanks for the response. Yes, when opened in new session the default tenant is set as specified in the kibana.yml.
“opendistro_security.multitenancy.tenants.preferred” is used to change ordering in the Tenants tab of Kibana. By default, the list starts with global and private (if enabled) and then proceeds alphabetically. You can add tenants here to move them to the top of the list. However, I still could not see this happening even in a new session.
Can you please check and let me know.
Thanks

@Pratiksha during all the various versions / set ups / testing I have never seen any options to change the sequence of tenants. Global and Private always appear first followed by custom tenants.