ODFE 1.13.0 Select your tenant

After upgrade to ODEF 1.13.0 I started seeing the new window like below every time I’m log in. Kibana multitenancy is disabled: opendistro_security.multitenancy.enabled: false Is there a way to disable such a behavior?

Also, this affects Reporting Plugin, so any PDF/PNG report has the same window in front of the main image. here is an example:

Same here. Post upgrade this box keeps showing up for users.

I just verified in the config.yaml and the kibana.yaml I have:

opendistro_security.multitenancy.enabled: false
opendistro_security.multitenancy.tenants.enable_global: false
opendistro_security.multitenancy.tenants.enable_private: false

Just did a simple test, setting the following, then informing users to check the checkbox to remember their tenant selection seems to have fixed the issue…

opendistro_security.multitenancy.enabled: true
opendistro_security.multitenancy.enable_filter: true
opendistro_security.multitenancy.tenants.preferred: ["Global"]
opendistro_security.multitenancy.tenants.enable_private: false