Not being able to create index_pattern when using index-name-* on odfe 1.11.0

Hi ODFErs,

I’m currently testing odfe v 1.11.0 with multitenancy support. I have created a role and mapped some users/backand-external to it. While defining the index permission i.e. crud, indices_all, index with index pattern index-name-* it doesn’t show anything to the users (only “Couldn’t find any Elasticsearch data
You’ll need to index some data into Elasticsearch before you can create an index pattern.”). But whenever I put only * with the same permission it allows users to create an index pattern.

Did someone else experience the same issue? or am I missing any of the permission/action-role to that specific index? I even tested setting up unlimited but it didn’t work either.

Thanks a lot in advance for your support.

Best,
Gezim

What you are describing sounds like this https://github.com/opendistro-for-elasticsearch/security-kibana-plugin/issues/529

1 Like

Thanks a lot, @oscark for your reply. Indeed, it seems the same issue :frowning: . Was wondering how we can (for now) manually add that resolve permission to that role/index-permission without specifying *? I mean, in case we specify * it will allow everyone to touch other’s indices and see everything.

Is there a way to use REST API to PUT such permission to that role/index?

Will be watching the discussion on that issue as well.

Best,

“touch other’s indices and see everything” != see the index name. This is what the resolve API does https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-resolve-index-api.html