Not able to Install openDistro for Elasticsearch RPM package centos 7 VM

#1

Hi all,

I am trying to install Open Distro -RPM package on a Centos 7 VM but this installation fails
(I have JDK installed), I followed the instructions don on installation page, I don’t know if there are some steps missed.
I get the message error messages below:
Error: Package: opendistro-sql-0.8.0.0-1.noarch (opendistroforelasticsearch-artifacts-repo)
Requires: elasticsearch-oss = 6.6.2
Error: Package: opendistroforelasticsearch-0.8.0-1.noarch (opendistroforelasticsearch-artifacts-repo)
Requires: elasticsearch-oss = 6.6.2
Error: Package: opendistro-security-0.8.0.0-1.noarch (opendistroforelasticsearch-artifacts-repo)
Requires: elasticsearch-oss = 6.6.2
Error: Package: opendistro-alerting-0.8.0.0-1.noarch (opendistroforelasticsearch-artifacts-repo)
Requires: elasticsearch-oss = 6.6.2
Error: Package: opendistro-performance-analyzer-0.8.0.0-1.noarch (opendistroforelasticsearch-artifacts-repo)
Requires: elasticsearch-oss = 6.6.2

Thanks a lot

Fred

#2

There is new elasticsearch-oss version 6.7.1 is available for upgrade, Due to fixed version dependency of opendistro* packages for elasticsearch-oss version 6.6.2, the elasticsearch-oss package update fails.

For now, you can update other packages using $ sudo yum update --skip-broken


[root@centos ~]# yum --showduplicates list elasticsearch-oss
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile

  • base: mirror.nbrc.ac.in
  • extras: mirror.nbrc.ac.in
  • updates: mirror.nbrc.ac.in
    Installed Packages
    elasticsearch-oss.noarch 6.6.2-1 @elasticsearch-6.x
    Available Packages
    elasticsearch-oss.noarch 6.3.0-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.3.1-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.3.2-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.4.0-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.4.1-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.4.2-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.4.3-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.5.0-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.5.1-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.5.2-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.5.3-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.5.4-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.6.0-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.6.1-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.6.2-1 elasticsearch-6.x <-- opendistro* dependency
    elasticsearch-oss.noarch 6.7.0-1 elasticsearch-6.x
    elasticsearch-oss.noarch 6.7.1-1 elasticsearch-6.x <-- new version
    [root@centos ~]#

#3

Good to know

I am going to re-do the installation, double check and come back to tell if this installation was successful.

Thank you

#4

So how do we fix this then?
I have a fresh centos 7 install, and I am trying to yum update, and I get the same error…

#5

Aah, I must have had a senior moment yesterday :slight_smile:
You mean there is actually not a valid update available, because opendistro does not yet support anything ES > 6.6.2 ?

#6

Correct. YUM attempts to update elasticsearch-oss to latest version which is from a separate repo,
Due to fixed version dependency on opendistro-* packages it fails and reports it as error.

(Sorry for late reply, somehow i missed the notifications… )

#7

Thanks.

I’m now using this:
sudo yum update --disablerepo=elasticsearch-6.x,opendistroforelasticsearch-artifacts-repo

Which excludes these updates, and is actually a good command to not accidentally update ES on a node :slight_smile: