Not able to enable the security on separate master node

I am running two separate docker. one for master node and one for data node with security feature enabled but Master node docker is giving below error like cluster state from YELLOW to RED

[2020-11-02T10:39:22,813][INFO ][o.e.g.GatewayService ] [odfe-master1] recovered [0] indices into cluster_state
[2020-11-02T10:39:22,820][WARN ][o.e.d.c.m.MetadataCreateIndexService] [odfe-master1] index name [.opendistro_security] starts with a dot ‘.’, in the next major version, index names starting with a dot are reserved for hidden indices and system indices
[2020-11-02T10:39:22,924][INFO ][o.e.c.m.MetadataCreateIndexService] [odfe-master1] [.opendistro_security] creating index, cause [api], templates , shards [1]/[1]
[2020-11-02T10:39:22,937][INFO ][o.e.c.r.a.AllocationService] [odfe-master1] Cluster health status changed from [YELLOW] to [RED] (reason: [index [.opendistro_security] created]).
[2020-11-02T10:39:52,982][INFO ][c.a.o.s.c.ConfigurationRepository] [odfe-master1] Index .opendistro_security created?: true

master node docker command

docker run --name odfe-master1 -d -p 9200:9200 -p 9300:9300 -p 9600:9600 -e “cluster.name=es-cluster” -e “node.name=odfe-master1” -e “cluster.initial_master_nodes=odfe-master1” -e “opendistro_security.disabled=false” -e “node.master=true” -e “node.data=false” -e “nofile=65536” -e “ES_JAVA_OPTS=”"-Xms512m -Xmx512m""" -e “network.publish_host=xx.xx.xx.xx” -e “transport.publish_host=xx.xx.xx.xx” amazon/opendistro-for-elasticsearch:1.11.0

But if i have use without node.data=false. then it working fine,

Can any one tell me how can we make security enables with only master node ?

1 Like

Please refer this:

Its resolved.