Minimum runtime environment for OS GA

What is the minimum Java version required to run (not build) OS GA?

Which JVM vendors will be tested (Corretto, AdoptOpenJDK, Oracle, …)?

Maybe we can have something like Elastic Support Matrix | Elasticsearch

2 Likes

That’s a really good question that I’ve never been asked (weirdly). For OpenSearch itself, the developer guide indicates testing back to JDK8 - but I’m not sure if that is true for the rest of plugins. The tarball includes includes an integrated JDK, so using that is probably the most well tested. Aside from that, let me dig around and see if we have an established answer to your questions that I just don’t know.

I love the idea of a version matrix - would you mind creating an issue on the website repo?

here we go: Add version matrix · Issue #143 · opensearch-project/project-website · GitHub

1 Like

Looks like it’s spawned a request for documentation as well!