Kibana won't start

I have a new set up of ES/Kibana (7.0.1) with the opendistro plugin. Everyting works fine with ES but when I start up Kibana, I get this error message in the plugin status page: "X-Pack Security needs to be disabled for Security to work properly. Please set ‘xpack.security.enabled’ to false in your kibana.yml. So if I add that directive to my kibana.yml, restart kibana, then kibana will not even start and I get this error message:

{“type”:“log”,"@timestamp":“2019-07-05T19:50:59Z”,“tags”:[“fatal”,“root”],“pid”:5379,“message”:"{ TypeError: Cannot read property ‘callWithRequest’ of undefined\n at getUserFn (/usr/share/kibana/node_modules/x-pack/plugins/reporting/server/lib/get_user.js:11:33)\n at /usr/share/kibana/node_modules/x-pack/plugins/reporting/server/lib/once_per_server.js:30:15\n at memoized (/usr/share/kibana/node_modules/lodash/index.js:7956:27)\n at authorizedUserPreRoutingFn (/usr/share/kibana/node_modules/x-pack/plugins/reporting/server/lib/authorized_user_pre_routing.js:14:19)\n at /usr/share/kibana/node_modules/x-pack/plugins/reporting/server/lib/once_per_server.js:30:15\n at memoized (/usr/share/kibana/node_modules/lodash/index.js:7956:27)\n at main (/usr/share/kibana/node_modules/x-pack/plugins/reporting/server/routes/main.js:25:36)\n at Plugin.init [as externalInit] (/usr/share/kibana/node_modules/x-pack/plugins/reporting/index.js:177:7)\n at process._tickCallback (internal/process/next_tick.js:68:7)\n isBoom: true,\n isServer: true,\n data: null,\n output:\n { statusCode: 500,\n payload:\n { statusCode: 500,\n error: ‘Internal Server Error’,\n message: ‘An internal server error occurred’ },\n headers: {} },\n reformat: [Function],\n [Symbol(SavedObjectsClientErrorCode)]: ‘SavedObjectsClient/generalError’ }"}

Any thoughs?

Hi @daleatav, you’re using the “default” version of Elasticsearch rather than the open source one. The default version has many proprietary features that overlap with the ones in Open Distro for Elasticsearch. If you can try again with OSS version, I think you’ll have better luck. Instructions here: https://opendistro.github.io/for-elasticsearch-docs/docs/install/plugins/#compatibility

Hello @aetter and thanks for the feedback. So if I have an existing ES install of 7.0.1, I won’t be able to use the “plugin method”? The way I read this is that I would have to install the OSS version from the PPA, correct?