Kibana Start Up Fails after invalid Security Update

Hello,

I am trying to set up AD / LDAP. I updated the config.yml and ran the securityadmin.sh

The output for that was success…However, I was unable to login with my AD user to Kibana…

I assumed may be it needed a restart and tried restarting Kibana…

However, Kibana start up is failing with the below message…

FATAL Error: Validation schema for [opendistro_security] was already registered.

I am sure something went wrong in the security set up…Now I am unable to bring up my Kibana services…

  1. How do I proceed ?
  2. How do I debug the AD set up issues…??

@vikramaddagulla
What is the ODFE version? Could you share your Kibana config?

Hello

ODFE version is : 1.13.2

Kibana Config…

# Copyright 2019 Amazon.com, Inc. or its affiliates. All Rights Reserved.
#
# Licensed under the Apache License, Version 2.0 (the "License").
# You may not use this file except in compliance with the License.
# A copy of the License is located at
#
#     http://www.apache.org/licenses/LICENSE-2.0
#
# or in the "license" file accompanying this file. This file is distributed
# on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either
# express or implied. See the License for the specific language governing
# permissions and limitations under the License.

# Description:
# Default Kibana configuration for Open Distro.

server.port: 5601
server.host: "0.0.0.0"
server.name: "********"

elasticsearch.hosts: https://localhost:9200
elasticsearch.ssl.verificationMode: none
elasticsearch.username: kibanaserver
elasticsearch.password: kibanaserver
elasticsearch.requestHeadersWhitelist: ["securitytenant","Authorization"]

opendistro_security.multitenancy.enabled: true
opendistro_security.multitenancy.tenants.preferred: ["Private", "Global"]
opendistro_security.readonly_mode.roles: ["kibana_read_only"]

# Use this setting if you are running kibana without https
opendistro_security.cookie.secure: false

newsfeed.enabled: false
telemetry.optIn: false
telemetry.enabled: false
security.showInsecureClusterWarning: false
# To configure a WMS map server for use with Kibana, see:
# https://opendistro.github.io/for-elasticsearch-docs/docs/kibana/maptiles/
map.includeElasticMapsService: false

Details replied…Please check and let me know if you could suggest something…?

Hello

Any updates please…??

I am stuck on this issue with no luck…

@vikramaddagulla

You could try following steps to get Kibana working again.

  1. Stop Kibana
  2. Remove security plugin in Kibana
  3. Comment out all security options in kibana.yml
  4. Run Kibana once
  5. Stop Kibana
  6. Install security plugin in Kibana and uncomment all security options.
  7. Start Kibana.