Kibana 1.0 not starting up with defaults

i have elasticsearch and kibana installed on the same box the versions are below

opendistroforelasticsearch-kibana-1.0.0-1.x86_64
opendistroforelasticsearch-1.0.0-1.noarch
opendistroforelasticsearch-kibana-1.0.0-1.x86_64

when logging in with the kibanserver user against a curl command i get a response back,

[root@elastic-opendistro-1 elasticsearch]# curl -u kibanaserver -p -k https://localhost:9200
Enter host password for user 'kibanaserver':
{
  "name" : "elastic-opendistro-1",
  "cluster_name" : "elasticsearch",
  "cluster_uuid" : "XZCiOpLeScqBG9KNPZCuzQ",
  "version" : {
    "number" : "7.0.1",
    "build_flavor" : "oss",
    "build_type" : "rpm",
    "build_hash" : "e4efcb5",
    "build_date" : "2019-04-29T12:56:03.145736Z",
    "build_snapshot" : false,
    "lucene_version" : "8.0.0",
    "minimum_wire_compatibility_version" : "6.7.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  },
  "tagline" : "You Know, for Search"
}

after installing kibana and firing it up i get the following error using the defaults indicated below

Jul  8 17:53:40 elastic-opendistro-1 systemd: kibana.service: main process exited, code=exited, status=1/FAILURE
Jul  8 17:53:40 elastic-opendistro-1 systemd: Unit kibana.service entered failed state.
Jul  8 17:53:40 elastic-opendistro-1 systemd: kibana.service failed.
Jul  8 17:53:40 elastic-opendistro-1 systemd: kibana.service holdoff time over, scheduling restart.
Jul  8 17:53:40 elastic-opendistro-1 systemd: Stopped Kibana.
Jul  8 17:53:40 elastic-opendistro-1 systemd: Started Kibana.
Jul  8 17:53:44 elastic-opendistro-1 kibana: {"type":"log","@timestamp":"2019-07-08T17:53:44Z","tags":["fatal","root"],"pid":5613,"message":"{ ValidationError: child \"elasticsearch\" fails because [\"url\" is not allowed]\n    at Object.exports.process (/usr/share/kibana/node_modules/joi/lib/errors.js:196:19)\n    at internals.Object._validateWithOptions (/usr/share/kibana/node_modules/joi/lib/types/any/index.js:675:31)\n    at module.exports.internals.Any.root.validate (/usr/share/kibana/node_modules/joi/lib/index.js:146:23)\n    at Config._commit (/usr/share/kibana/src/legacy/server/config/config.js:139:35)\n    at Config.set (/usr/share/kibana/src/legacy/server/config/config.js:108:10)\n    at Config.extendSchema (/usr/share/kibana/src/legacy/server/config/config.js:81:10)\n    at extendConfigService (/usr/share/kibana/src/legacy/plugin_discovery/plugin_config/extend_config_service.js:45:10) name: 'ValidationError' }"}
Jul  8 17:53:44 elastic-opendistro-1 kibana: FATAL  ValidationError: child "elasticsearch" fails because ["url" is not allowed]
Jul  8 17:53:44 elastic-opendistro-1 systemd: kibana.service: main process exited, code=exited, status=1/FAILURE

kibana.yml file

# Copyright 2019 Amazon.com, Inc. or its affiliates. All Rights Reserved.
#
# Licensed under the Apache License, Version 2.0 (the "License").
# You may not use this file except in compliance with the License.
# A copy of the License is located at
#
#     http://www.apache.org/licenses/LICENSE-2.0
#
# or in the "license" file accompanying this file. This file is distributed
# on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either
# express or implied. See the License for the specific language governing
# permissions and limitations under the License.

# Description:
# Default Kibana configuration for Open Distro.

elasticsearch.url: https://localhost:9200
elasticsearch.ssl.verificationMode: none

elasticsearch.username: kibanaserver
elasticsearch.password: kibanaserver
elasticsearch.requestHeadersWhitelist: ["securitytenant","Authorization"]

opendistro_security.multitenancy.enabled: true
opendistro_security.multitenancy.tenants.preferred: ["Private", "Global"]
opendistro_security.readonly_mode.roles: ["kibana_read_only"]

if kibana is not using ssl verification mode and just username and password it should fire up so im not understanding were the problem is here?

Hi,

please have a look here: Debian package opendistroforelasticsearch-kibana 1.0.0 does not work

You might need to consider the breaking changes that comes with kibana’s major release 7.x -> https://www.elastic.co/guide/en/kibana/7.0/breaking-changes-7.0.html

thanks,
nean

Hi @ramzey1981, Elastic changed elasticsearch.url to elasticsearch.hosts. I actually include both in the Docker configuration because I can never remember which is which. I think you’ll have better luck if you just swap in the new setting.