Issue with kibana multitenancy when enabled with ingress

I am using kibana security plugin 1.9.0 and have enabled multitenancy. I have ingress enabled in cluster. With this, after selecting a tenant in Tenants Tab through SELECT button and then navigating to any screen (visualize/dashoboard screens) from sidebar menu in kibana getting error as below saying 404 not found:


I observed that the url is getting reformed when I select from sidebar menu after selecting a tenant from SELECT button, the server.basePath specified in ingress section gets removed from url.
For eg. the url before the issue: https:///ingresspath/app/kibana
After following the above sceanrio, the url becomes: https:///app/kibana

Please have a look and suggest.
Thanks

I’m on 1.12 AFAIK the url should be /app/visualize not /app/kibana/ . I have no clue but I’m wondering if you are using some proxy and you have server.rewriteBasePath configured as false when it should be true.

@Pratiksha Could you share your config files? (elastic, kibana and config.yml)

Hi @pablo
Please find below multitenancy configuration done.
Elasticsearch config:
config:
dynamic:
kibana:
multitenancy_enabled: true
server_username: kibanaserver
Kibana config:
opendistro_security.multitenancy.enabled: true
elasticsearch.requestHeadersWhitelist: [ “Authorization”, “securitytenant”, “x-forwarded-for”, “x-proxy-user”, “x-proxy-roles” ]