Indices failing to rollover

I am currently trying to index rollovers to better balance load on our cluster. However, every time an index is supposed to rollover I get an error just saying “Failed to rollover index”. I’m not really sure what the issue is, I must be missing something. Any help would be appreciated.

Here is some info from an index that is failing to rollover:

Policy:

Summary
{
  "_id" : "rollover_policy",
  "_version" : 1,
  "_seq_no" : 0,
  "_primary_term" : 1,
  "policy" : {
    "policy_id" : "rollover_policy",
    "description" : "Demonstrate a hot-warm-delete workflow.",
    "last_updated_time" : 1595249267790,
    "schema_version" : 1,
    "error_notification" : null,
    "default_state" : "hot",
    "states" : [
      {
        "name" : "hot",
        "actions" : [
          {
            "retry" : {
              "count" : 10,
              "backoff" : "exponential",
              "delay" : "10m"
            },
            "rollover" : {
              "min_size" : "1gb",
              "min_index_age" : "7d"
            }
          }
        ],
        "transitions" : [
          {
            "state_name" : "warm",
            "conditions" : {
              "min_index_age" : "7d"
            }
          }
        ]
      },
      { ... }
  }
}

Template:

Summary
{
  "foo-template" : {
    "order" : 0,
    "index_patterns" : [
      "foo--*"
    ],
    "settings" : {
      "index" : {
        "number_of_shards" : "3",
        "number_of_replicas" : "1",
        "opendistro" : {
          "index_state_management" : {
            "policy_id" : "rollover_policy",
            "rollover_alias" : "foo"
          }
        }
      }
    },
    "mappings" : { },
    "aliases" : {
      "foo" : { }
    }
  }
}

Index:

Summary
{
  "foo--000001" : {
    "aliases" : {
      "foo" : {
        "is_write_index" : true
      }
    },
    "mappings" : { ... },
    "settings" : {
      "index" : {
        "opendistro" : {
          "index_state_management" : {
            "policy_id" : "rollover_policy",
            "rollover_alias" : "foo"
          }
        },
        "number_of_shards" : "3",
        "provided_name" : "<foo--000001>",
        "creation_date" : "1595249860144",
        "number_of_replicas" : "1",
        "uuid" : "IXahlazCRVqJ7V8a_NitSg",
        "version" : {
          "created" : "7040299"
        }
      }
    }
  }
}

ISM Explain:

Summary
{
  "foo--000001" : {
    "index.opendistro.index_state_management.policy_id" : "rollover_policy",
    "index" : "foo--000001",
    "index_uuid" : "IXahlazCRVqJ7V8a_NitSg",
    "policy_id" : "rollover_policy",
    "policy_seq_no" : 0,
    "policy_primary_term" : 1,
    "rolled_over" : false,
    "state" : {
      "name" : "hot",
      "start_time" : 1595251810392
    },
    "action" : {
      "name" : "rollover",
      "start_time" : 1595253700782,
      "index" : 0,
      "failed" : false,
      "consumed_retries" : 3,
      "last_retry_time" : 1595257245637
    },
    "retry_info" : {
      "failed" : false,
      "consumed_retries" : 0
    },
    "info" : {
      "cause" : "[e3caee2d0d3beecd043217b04dbbf242][...:9300][indices:admin/rollover]",
      "message" : "Failed to rollover index"
    }
  }
}

This apparently is an issue using amazon hosted elasticsearch with their ultrawarm nodes. It has a bug where rollovers constantly fail. They said they have a fix ready for it but wouldn’t give me an ETA.