Index not showing up in kibana

Hi

I have the data in elastic search, i can see data in dev tools as well in kibana but cannot create index in kibana with the same name or its not appearing in kibana create index pattern, please check below snaps:

please check kibana.yml:

elasticsearch.hosts: http://localhost:9200

#elasticsearch.ssl.verificationMode: none

elasticsearch.username: admin

elasticsearch.password: admin

elasticsearch.requestHeadersWhitelist: [“securitytenant”,“Authorization”]

logging.dest: /var/log/kibana/kibana.log

opendistro_security.multitenancy.enabled: false

opendistro_security.multitenancy.tenants.preferred: [“Private”, “Global”]

opendistro_security.readonly_mode.roles: [“kibana_read_only”]

newsfeed.enabled: false

telemetry.optIn: false

telemetry.enabled: false

Please guide where could be the mistake, i see data flowing from filebeat to logstash to elasticsearch but cannot visualize in kibana cannot create index pattern

Addition info:

curl http://localhost:9200/_cat/indices?v

@rushabhdoshi9 Which tenant is the active tenant? Some of our users have reported “everything is gone” when the real problem is just that they have the wrong tenant active. Click on the TENANTS (person’s head and shoulder) icon and make sure GLOBAL tenant is the “active” one.

How to check which tenant is active or make one active, i have the below two in list @GSmith

Below is my kibana.yml:

elasticsearch.hosts: http://localhost:9200

#elasticsearch.ssl.verificationMode: none

elasticsearch.username: admin

elasticsearch.password: cleartext

elasticsearch.requestHeadersWhitelist: [“securitytenant”,“Authorization”]

logging.dest: /var/log/kibana/kibana.log

opendistro_security.multitenancy.enabled: false

opendistro_security.multitenancy.tenants.preferred: [“Private”, “Global”]

opendistro_security.readonly_mode.roles: [“kibana_read_only”]

newsfeed.enabled: false

telemetry.optIn: false

telemetry.enabled: false

You need to do it in the Kibana UI. Click on the TENANTS option in the left-side menu…then click the SELECT button on the far right side on the row for the GLOBAL tenant. Here’s how it looks in ODFE Kibana 1.7.0:

As you can see i have disabled multi-tenancy: opendistro_security.multitenancy.enabled: false

I do not see the tenants icon in the left-hand side panel, what would be the default? Is there any issue in that