How to configure proxy for alert destinations

I’m running OpenDistro for elasticsearch and Kibana on CentOS7 virtual machine.

I ran into an issue that my slack webhook is not reachable from ODfES
Previous topic

I think the issue I have is, I’m behind a proxy.

I found that http proxy support was added with this PR
But I couldn’t find proper details/document on how to configure this.

Installed Packages
opendistroforelasticsearch.noarch: 0.9.0-1
opendistroforelasticsearch-kibana.x86_64: 0.9.0-1

On the host, i have already added the proxy as environment variable
Note: yum etc works fine with the proxy

[root@t<Host>]# cat /etc/environment
http_proxy=http://proxy.example.com:80
https_proxy=http://proxy.example.com:80

furthermore as I mentioned in my previous topic slack endpoint works/reachable via curl

[root@SourceHost ~]# curl -X POST -H "Content-Type: application/json"  -d '{"text":"Failed Login Attempt on  \n\n Monitor Windows authentication failures just entered alert status. Please investigate the issue.\n- Trigger: Windows authentication failures - Trigger\n- Severity: 1\n- Period start: 2019-05-28T00:18:12.394Z\n- Period end: 2019-05-28T00:19:12.394Z"}' https://hooks.slack.com/services/blah/blah/blaaaaaaaaaaaaaaaaaah
ok
[root@SourceHost ~]#

Can someone help me on this.

Damn… Finally got it working after few days

If you are behind a proxy you need to add below configs to your “/etc/elasticsearch/jvm.options” file

-Dhttp.proxyHost=proxy.example.com
-Dhttp.proxyPort=80
-Dhttps.proxyHost=proxy.example.com
-Dhttps.proxyPort=80

With this changes, you need to restart elasticsearch and you are good to go.

1 Like