Error installing 1.0 unmet dependencies

I getting error installing opendistro on ubuntu 18 for unmet dependencies … It needs elasticsearch-oss 7.0.1, not sure where to get it … I installed elasticsearch-7.0.1-amd64.deb , OD install still complains about unmet dependencies . I tried apt-get install -f and still got unmet dependencies .

You need to download oss-one
https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-oss-7.0.1-amd64.deb
https://www.elastic.co/downloads/past-releases/elasticsearch-oss-7-0-1