Elasticsearch on Kubernetes - low ulimit

Trying to deploy the Opendistro ES to a Kubernetes cluster (based on https://github.com/opendistro-for-elasticsearch/community/tree/master/open-distro-elasticsearch-kubernetes)

However - I am unable to start the ES pod as it claims the ulimit nofile is too low:

max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]

Currently trying on minikube, but the destination cluster is AKS (Azure Kubernetes Service), yet I have little control over the cluster nodes

I was trying to update system values:

  initContainers:
  - name: init-sysctl-mapcount
    image: busybox:1.27.2
    command: ["sh", "-c", "sysctl -w vm.max_map_count=262144"]
    securityContext:
      privileged: true
  - name: init-ulimitn
    image: busybox:1.27.2
    command: ["sh", "-c", "ulimit -n 65536"]
    securityContext:
      privileged: true

where the sysctl command resolved the vm.max_map_count parameter, seems the ulimit stays low even mounting a limits.conf file with extended limits

This issue appears using minikube, when deploying to EKS or AKS, seems the ulimits are updated by the initContainers statements