Elastic search support for 6.8.4 or 6.2.3

Hi We are working with Elasandra OSS release (Elastic Search + Apache Casandra) GitHub - strapdata/elassandra: Elassandra = Elasticsearch + Apache Cassandra. We are looking to add opendistro for elastic search for security aspect. Is there any plan for support for elastic search version 6.8.4 or 6.2.3?

:wave: Welcome Ameya!

If you take a look at our docs, we supported 6.8.x in 0.10.0 of Open Distro. We do keep a list of artifacts for previous versions, but it doesn’t go back that far.

If you need only the security plugin, you can use just the security plugin in your project. Open Distro is plugins + Apache 2.0 Elasticsearch/Kibana, so I think you already have half that equation. While we don’t have the artifact going that far back, you can compile the plugin from the github branch and use it as you’d like.

I dont see version 1.10.0 but 1.10.1 only. Previous Versions - Open Distro for Elasticsearch Documentation
Also we are looking to install opendistro security plugin in this case what has to be done ?

I have been referring to you plugin supported ES version document on link Standalone Elasticsearch Plugin Install - Open Distro for Elasticsearch Documentation don’t see support for 6.8.4 elastic search we tried to install 6.8.1 but getting version mismatch error.