Elastic Search is getting crashed after running KNN query

I am using OpenDistro ES version 7.4.2 and Kibana 7.4.2. I have added the KNN plugin of version 1.4.0.0-1.
ES and KIbana is running fine but after creating the indices using following query

PUT /myindex
{
“settings” : {
“index”: {
“knn”: true,
“knn.algo_param.m”:90,
“knn.algo_param.ef_construction”:200,
“knn.algo_param.ef_search”:300
}
},
“mappings”: {
“properties”: {
“my_vector1”: {
“type”: “knn_vector”,
“dimension”: 2
},
“my_vector2”: {
“type”: “knn_vector”,
“dimension”: 2
},
“my_vector3”: {
“type”: “knn_vector”,
“dimension”: 2
}
}
}
}

My ES is getting crashed. There is no error log but found a file named as hs_err_pid12902.log under /var/log/elasticsearch directory.

Problematic frame:

C [libKNNIndexV1_7_3_6.so+0xcb10a] _GLOBAL__sub_I_distcomp_sparse_scalar_fast.cc+0x2a

ES get crashed sometimes with GET, few times during data insertion and mostly with search

Query used
POST myindex/_doc/1
{
“my_vector1” : [1.5, 2.5]
}

POST myindex/_doc/2
{
“my_vector1” : [2.5, 3.5]
}

POST myindex/_doc/3
{
“my_vector1” : [4.5, 5.5]
}

POST myindex/_search
{
“size” : 2,
“query”: {
“knn”: {
“my_vector1”: {
“vector”: [1.5, 2.5],
“k”: 1
}
}
}
}

===
GET _cat/indices

====
Error during insertion of data

POST myindex/_doc/1

{
“_index” : “myindex”,
“_type” : “_doc”,
“_id” : “1”,
“_version” : 1,
“result” : “created”,
“_shards” : {
“total” : 2,
“successful” : 1,
“failed” : 0
},
“_seq_no” : 0,
“_primary_term” : 1
}

POST myindex/_doc/2

{
“message”: “Client request error: connect ECONNREFUSED x.x.x.x:9200”,
“statusCode”: 502,
“error”: “Bad Gateway”
}

Followed up in https://github.com/opendistro-for-elasticsearch/k-NN/issues/95