Downloading and Installing specific version of elasticsearch 6.5.4

I am trying download RPMs for specific version of elasticsearch ( say 6.5.4 ).
when I try

cd /etc/yum.repos.d/
sudo curl https://d3g5vo6xdbdb9a.cloudfront.net/yum/opendistroforelasticsearch-artifacts.repo -o opendistroforelasticsearch-artifacts.repo

# Make a folder to store rpms
cd ~
mkdir ODFErpms

# download rpms for a specific release version
sudo yum install --downloadonly --downloaddir=ODFErpms opendistroforelasticsearch-0.7.1

I get the following error. is there a work around for this issue ?

Error: Package: opendistro-alerting-0.7.0.0-1.noarch (opendistroforelasticsearch-artifacts-repo)
           Requires: elasticsearch-oss = 6.5.4
           Available: elasticsearch-oss-6.3.0-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.3.0-1
           Available: elasticsearch-oss-6.3.1-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.3.1-1
           Available: elasticsearch-oss-6.3.2-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.3.2-1
           Available: elasticsearch-oss-6.4.0-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.4.0-1
           Available: elasticsearch-oss-6.4.1-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.4.1-1
           Available: elasticsearch-oss-6.4.2-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.4.2-1
           Available: elasticsearch-oss-6.4.3-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.4.3-1
           Available: elasticsearch-oss-6.5.0-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.5.0-1
           Available: elasticsearch-oss-6.5.1-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.5.1-1
           Available: elasticsearch-oss-6.5.2-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.5.2-1
           Available: elasticsearch-oss-6.5.3-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.5.3-1
           Available: elasticsearch-oss-6.5.4-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.5.4-1
           Available: elasticsearch-oss-6.6.0-1.noarch (elasticsearch-6.x)
               elasticsearch-oss = 6.6.0-1

I appreciate any help or advice on this issue

1 Like

which version of elasticsearch oss you have installed on your system?? I think there is version mismatch of elasticsearch oss.

I am trying to download and install elasticsearch 6.5.4 . Its a brand new ec2 instance. it doesnt have any elasticsearch installed.

0.7.0 Initial release. 11 March 2019 6.5.4
From version History I am able to see that for opendistro 0.7.0 You need to install elastic 6.5.4
What isssue you are facing while installling elasticsearch oss