Configuring TLS (https) for Kibana only - issue accessing with FQDN

Here is my configuration. Successfully works for (cert is generated for myServer.mydomain.com)
https://myServer.mydomain.com:5601

browser errors with invalid cert for https://myServer:5601

How do I allow both of these urls to work ? Do i need to two certs (myServer and myServer.mydomain.com). If so how do I specify in the config below.

Relevant Snippets of kibana.yml

elasticsearch.hosts: https://localhost:9200
elasticsearch.ssl.verificationMode: none
elasticsearch.username:
elasticsearch.password:
elasticsearch.requestHeadersWhitelist: [“securitytenant”,“Authorization”]

opendistro_security.multitenancy.enabled: false
opendistro_security.multitenancy.tenants.enable_global: true
opendistro_security.multitenancy.tenants.enable_private: false
opendistro_security.multitenancy.tenants.preferred: [“Global”,“Private”]
opendistro_security.readonly_mode.roles: [“kibana_read_only”]

server.host: myServer
logging.verbose: true

Kibana TLS Config

server.ssl.enabled: true
server.ssl.key: /appl/ELK/opendistroforelasticsearch-kibana/CERTS/myServer-key.pem
server.ssl.certificate: /appl/ELK/opendistroforelasticsearch-kibana/CERTS/myServer–cert.pem

opendistro_security.cookie.secure: true