After migrating from ODFE 1.13.2 to OpenSearch 1.1.0, we get a lot of errors in elasticsearch logs

We are seing a lot of these logs in the elasticsearch logs:

[2021-10-13T13:03:07,555][DEPRECATION][o.o.d.c.m.IndexNameExpressionResolver] [tkshei-es01] this request accesses system indices: [.opendistro_security], but in a future major version, direct access to system indices will be prevented by default
[2021-10-13T13:03:07,555][DEPRECATION][o.o.d.c.m.IndexNameExpressionResolver] [test-es01] this request accesses system indices: [.opendistro_security], but in a future major version, direct access to system indices will be prevented by default
[2021-10-13T13:04:07,555][DEPRECATION][o.o.d.c.m.IndexNameExpressionResolver] [test-es01] this request accesses system indices: [.opendistro_security], but in a future major version, direct access to system indices will be prevented by default
[2021-10-13T13:04:07,555][DEPRECATION][o.o.d.c.m.IndexNameExpressionResolver] [test-es01] this request accesses system indices: [.opendistro_security], but in a future major version, direct access to system indices will be prevented by default

Is this normal? What should we do about it?

We’re running this on Kubernetes so we just changed the image to use opensearch and updated the configfiles to opensearch compatible syntax.

This is a known issue: