About "Tenant indices migration failed" error in kibana

#1

Hello, every time I restart my stack and try o access kibana I get this error, didn’t find anything about this on the internet.

Any ideas how to solve it? thanks in advance.

1 Like
Kibana fails to start
#2

Hello mate !
I had the same issue, I fixed it by uncommenting the line in one of the file : /usr/share/kibana/plugins/opendistro_security/lib/multitenancy/migrate_tenants.js

Uncomment, remove the //, in front of the line :
import { KibanaMigrator } from ‘…/…/…/…/src/server/saved_objects/migrations’;

Hope it helps.
Thi

1 Like
Empty contents for Official Kibana Discover/Visualize
#3

Nice one, big oof for the current kibana version tho, not very pretty having this on my docker-compose :sweat_smile:

volumes:
  - ./migrate_tenants.js:/usr/share/kibana/plugins/opendistro_security/lib/multitenancy/migrate_tenants.js
#4

We have an issue open tracking this. We have created a fix for the issue. It will show up in the next release. Thanks!

#5

i wanna show this to my colleague … and this prob mess my demo …
Update asap !!! Please !!!

#6

@edelavaud in the meantime while we are getting this out, if you are using docker for your demo you can bypass this issue by wiping the volume when standing up the containers with the -v flag. For example using our docker-compose setup, you can start it with docker-compose -v and it should delete the data volume and rebuild with a clean setup.

#7

Thanks. I also have error “Tenant indicies migration failed” and can solve like above.

#8

is it work for single node also ? i don’t have multi node cluster.

#9

Hello !
I tested on single node and it worked for me.
Just have to uncomment the line and all fine.

Thi

#11

Hi Thi,

Are you using the RPM or the Docker version of Opendistro?

#12

Hi apai, I use the RPM version for now.

Thi

#13

please tell what is the date of the next release?

#14

New docker and RPM version (0.7.1) is now released to address this bug.

More details: https://opendistro.github.io/for-elasticsearch-docs/#version-history

1 Like
#15

Thank you !
Do you have some guide for updating Open Distro for Elasticsearch?

Thi

#16

I use the 0.8.0, the same issue comes back. I checked the file /usr/share/kibana/plugins/opendistro_security/lib/multitenancy/migrate_tenants.js, it is correct.
can someone help check it?

Open Distro Multitenancy Error
#17

the default install has no issue, my issue is due to the custom .kibana index, which account don’t have access.

#18

I’m having this same problem with 0.7.0.1

Did you find a solution?

#19

Hi,

You can fix it by disabling multitenancy in default kibana configuration. Change this line opendistro_security.multitenancy.enabled: true
to
opendistro_security.multitenancy.enabled: false

Path for default config file in docker is /usr/share/kibana/config/kibana.yml.

#20

I needed multi tenancy enabled for my use case.
I was able to resolve by going to my Elasticsearch Directory, and going to
/elasticsearch/plugins/opendistro_security/securityconfig/config.yml

and un-commenting
kibana:
# Kibana multitenancy -
# see
# To make this work you need to install
multitenancy_enabled: true
server_username: admin
index: ‘.kibana’
do_not_fail_on_forbidden: false

#21

I was also getting this error. I am using docker version for elasticsearch and kibana. I believe it was because the elasticsearch nodes were not running.